Wednesday, October 31, 2007

Codeplex IdentitySelector 1.0.2

I just uploaded a new version 1.0.2 of the identity selector selector Firefox extension.

Firefox


You can find the XPI and the source code zip-archive on the Codeplex IdentitySelector release page. Please click the "IdentitySelector-1.0.2.xpi" link to install this extension into Firefox.

So, what's new?
  • issuerPolicy is now supported
  • no-SSL should now be supported. Not tested. You need .NET 3.5 (CardSpace 1.x) to test this.
  • report errors to javascript console
  • tokenType may be null
  • requiredClaims may be null
  • javascript errors in InformationCard.xml are fixed


Here are two pictures showing Microsoft's ageSTS before and after login using this new version of the Firefox extension with CardSpace 1.0 as the identity selector:




This needs more tests and sometimes shows the dreaded "Additional plugins are required to display all the media on this page" status bar.



Please try it and report issues to me.

1 comment:

Ashish said...

Congratulations Axel. You seem to be on top of this.
- Ashish.